Virus on CCIE BootCamp Indonesia 2011

Ketika nomor itu semakin mendekat ….

Archive for the ‘MPLS’ Category

MPLS ..

leave a comment »

Hari ke 5 sesi 1 jam 9 pagi dimulai dengan pelajaran MPLS., sebenarnya MPLS banyak dipakai di teknologi Service Provider tapi bukan karena itu kita jadi ga belajar mpls .. ya kan :D..  nah menurut mas Dedi (aka pengajar butkemp), soal- soal mpls ga banyak muncul tapi bobotmya ganas artinya penting…., makanya kita pelajari .. hehe.

Jujur sebenarnya lumayan ribet untuk teknologi ini dan .. fiuuh benaran..,  soalnya support untuk belajarnya ga selengkap seperti belajar routing yang lain, seperti misalnya mau coba mpls AToM (Any Transport Over MPLS) .. nah itu pake switch juga .. nah loh ,, simulator ga bisa nih, harus pake switch .. hehe tapi gpp kita akan coba cari cara untuk melakukan labnya.

ok, disini akan coba di share sedikit mengenai MPLS, mpls singkatan dari Multiprotocol Label Switching adalah teknologi penyampaian paket pada jaringan backbone berkecepatan tinggi.

MPLS umumnya terdiri dari 3 jenis router yaitu:

 

1. Router P (Provider)

Berada di dalam domain MPLS, dan P terhubung dengan router P lainnya yang dimiliki service provider

Pada jaringan yang tidak terlalu besar, kemungkinan tidak terdapat router P, hal ini dapat menghemat biaya.

2. Router PE (Provider Edge)

Router yang terdapat diantara router P dengan router customer, merupakan penghubung antara network berbasi IP dengan MPLS.

Router PE berfungsi untuk memberikan label pada paket IP yang masuk ke dalam dan melepasnya ke luar domain MPLS.

3. Router CE (Customer Edge)

Router terdapat pada sisi customer, dan tidak memiliki konfigurasi MPLS hanya routing biasa dapat static maupun dinamik seperti RIP, OSPF atau ISIS.

 

Tahapan konfigurasinya adalah:

1. Berikan konifugrasi kepada semua interface router

2. Aktifkan dynamic routing

3. Aktifkan BGP

4. Aktifkan MPLS

 

Ok, ayo kita lakukan konfigurasi sederhana dari lab hari ini, diambil dari lab 1 MPLS Backbone:

Konfigurasi IP address, set konfigurasi ini pada tiap interface

 

 

Router PE1

PE1#conf t
PE1(config)#int se 0/0
PE1(config-if)#ip add 192.168.10.1 255.255.255.252
PE1(config-if)#description Link to P router
PE1(config-if)#int lo0
PE1(config-if)#ip ad 10.10.10.1 255.255.255.255
PE1(config-if)#end

 

Router P

P(config)#int se 0/0
P(config-if)#ip add 192.168.10.2 255.255.255.252
P(config-if)#desc Link to PE1 router
P(config-if)#no sh
P(config-if)#int se 0/1
P(config-if)# ip add 192.168.20.1 255.255.255.252
P(config-if)#desc Link to PE2 router
P(config-if)#no sh
P(config-if)#end

 

Router PE2

PE2(config)#int se 0/1
PE2(config-if)#ip add 192.168.20.2 255.255.255.252
PE2(config-if)#no sh
PE2(config-if)#desc Link to P router
PE2(config-if)#int lo0
PE2(config-if)#ip add 10.10.10.2 255.255.255.255
PE2(config-if)#end

 

Setelah semua sudah dikonfigurasi lakukan test ping ke masing- masing interface:

PE1: ping 192.168.10.2P  : ping 192.168.10.1

P  : ping 192.168.20.2

PE2: ping 192.168.20.1

 

kita masuk ke tahap 2 untuk mengaktifkan dynamic routing (OSPF)

Dynamic routing berfungsi agar semua router dalam domain MPLS dapat saling berkomunikasi.

 

Router PE1

PE1(config)#router ospf 1
PE1(config-router)#network 192.168.10.1 0.0.0.0 area 0
PE1(config-router)#network 10.10.10.1 0.0.0.0 area 0
PE1(config-router)#end

 

Router P

P(config)#router ospf 1
P(config-router)#network 192.168.10.2 0.0.0.0 area 0
P(config-router)#network 192.168.20.1 0.0.0.0 area 0
P(config-router)#network 10.10.10.10 0.0.0.0 area 0
P(config-router)#end

 

Router PE2

PE2(config)#router ospf 1
PE2(config-router)#network 192.168.20.2 0.0.0.0 area 0
PE2(config-router)#network 10.10.10.2 0.0.0.0 area 0
PE2(config-router)#end

 

Setelah semua sudah dikonfigurasi maka lihat routing table pada semua router

#show ip route

dan lakukan test ping terhadap semua ip loopback interface

#ping 10.10.10.1
#ping 10.10.10.2
#ping 10.10.10.10

Lanjuut..  kita aktifkan BGP

 

BGP ini penting karena nantinya akan melewatkan informasi seperti routing, vpn dan vrf, ini semua dilakukan MP-BGP dan hanya dikonfigurasi pad masing- masing PE router saja.

 

Router PE1

PE1(config)#router bgp 65000
PE1(config-router)#neighbor 10.10.10.2 remote-as 65000
PE1(config-router)#neighbor 10.10.10.2 update-source loopback 0
PE1(config-router)#end

 

Router PE2

PE2(config)#router bgp 65000
PE2(config-router)#neighbor 10.10.10.1 remote-as 65000
PE2(config-router)#neighbor 10.10.10.1 update-source loopback 0
PE2(config-router)#end
Lakukan verifikasi BGP peering apakah berhasil atau tidak
#show ip bgp

 

Mengaktifkan MPLS

Untuk konfigurasi ini dilakukan pada semua router baik P ataupun PE.

Router PE1

PE1(config)#mpls ip
PE1(config)#int se 0/0
PE1(config-if)#mpls ip
PE1(config-if)#end

 

Router PE2

PE2(config)#mpls ip
PE2(config)#int se 0/1
PE2(config-if)#mpls ip
PE2(config-if)#end

 

Router P

P(config)#mpls ip
P(config)#int se 0/0
P(config-if)#mpls ip
P(config-if)#int se0/1
P(config-if)#mpls ip
P(config-if)#end

 

Lalu lakukan perintah berikut untuk melakukan pengecekan:

#show mpls forwarding-table

PE1#show mpls for
PE1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     192.168.20.0/30   0          Se0/0      point2point
17     Pop tag     10.10.10.10/32    0          Se0/0      point2point
18     16          10.10.10.2/32     0          Se0/0      point2point

 

Dari informasi di atas kita dapat lihat bahwa mpls sudah jalan. :), dibuktikan dari adalah label .. itu tu .. yang angka 16, 17, dan 18 .. berarti sudah aman. … MPLS kita berhasil ..  (tepuk pramuka..  plok plok plok)..

Written by virusccie

December 10, 2011 at 2:10 am

Posted in MPLS