Virus on CCIE BootCamp Indonesia 2011

Ketika nomor itu semakin mendekat ….

IPv6 bertemu dengan OSPF …

leave a comment »

… masih di seputaran EIGRP, OSPF , Mutual Distribution dan IPv6 ..

gimana dengan beberapa lab yang sudah dibahas.. kurang ya??  sebenarnya labnya banyak bgt dan pastinya bagus buat latihan- latihan sebelum ngambil ujian lab..

Lab akan dibahas semua tapi bertahap ya ..  🙂 .., sekarang aku  tambahin 1 topologi lagi untuk belajar …

baik .. untuk bahasan (red: Mutual Distribution, IPv6, EIGRP, dan OSPF) .. aku coba buat 1 topology simpel yang gabungin ke 4 topik tersebut. Topologinya ga akan ane-aneh .. bener2, simpel ko .. ayoo dilihat  🙂

Sudah dilihatnya .. langsung kita konfigure .. nih dia ..

Ketik ini pada R1

R1>en
R1#conf t
R1(config)#ipv6 unicast-routing
R1(config-if)#int fa0/0
R1(config-if)#ipv6 add 12::1/64
R1(config-if)#no sh
R1(config-if)#int fa 0/1
R1(config-if)#ipv6 add 13::1/64
R1(config-if)#no sh
R1(config)#ipv6 router eigrp 1
R1(config-rtr)#no shutdown
R1(config-rtr)#eigrp router-id 1.1.1.1
R1(config-rtr)#exit
R1(config)#int fa0/0
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int fa0/1
R1(config-if)#ipv6 eigrp 1
R1(config-if)#int lo0
R1(config-if)#ipv6 eigrp 1
R1(config-if)#end

 

buat R2

R2(config)#int fa0/0
R2(config-if)#ipv6 add 12::2/64
R2(config-if)#no sh
R2(config-if)#int fa 0/1
R2(config-if)#ipv6 add 24::2/64
R2(config-if)#no sh
R2(config-if)#int lo0
R2(config-if)#ipv6 add 2::2/128
R2(config-if)#exit
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#no shutdown
R2(config-rtr)#eigrp router-id 2.2.2.2
R2(config-rtr)#exit
R2(config)#int fa 0/0
R2(config-if)#ipv6 eigrp 1
R2(config-if)#int fa0/1
R2(config-if)#ipv6 eigrp 1
R2(config-if)#int lo0
R2(config-if)#ipv6 eigrp 1
R2(config-if)#end

 

R3

R3(config)#ipv6 unicast-routing
R3(config)#int lo0
R3(config-if)#ipv6 add 3::3/128
R3(config-if)#int fa0/0
R3(config-if)#ipv6 add 13::3/64
R3(config-if)#no sh
R3(config-if)#int fa0/1
R3(config-if)#no sh
R3(config-if)#ipv6 add 35::3/64
R3(config-if)#exit
R3(config)#ipv6 router eigrp 1
R3(config-rtr)#no sh
R3(config-rtr)#eigrp router-id 3.3.3.3
R3(config-rtr)#exit
R3(config)#int lo 0
R3(config-if)#ipv6 eigrp 1
R3(config-if)#int fa 0/0
R3(config-if)#ipv6 eigrp 1
R3(config-if)#int fa 0/1
R3(config-if)#ipv6 eigrp 1
R3(config)#ipv6 router ospf 1
R3(config-rtr)#router-id 3.3.3.3
R3(config-rtr)#exit
R3(config)#int fa0/1
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#end

 

buat R4

R4(config)#ipv6 unicast-routing
R4(config)#int lo0
R4(config-if)#ipv6 add 4::4/128
R4(config-if)#int fa 0/0
R4(config-if)#ipv6 add 24::4/64
R4(config-if)#no sh
R4(config-if)#int fa 0/1
R4(config-if)#no sh
R4(config-if)#ipv6 add 46::4/64
R4(config-if)#exit
R4(config)#ipv6 router eigrp 1
R4(config-rtr)#no sh
R4(config-rtr)#eigrp router-id 4.4.4.4
R4(config-rtr)#exit
R4(config)#int fa0/0
R4(config-if)#ipv6 eigrp 1
R4(config-if)#exit
R4(config)#ipv6 router ospf 1
R4(config-rtr)#
R4(config-rtr)#router-id 4.4.4.4
R4(config-rtr)#exit
R4(config)#int fa0/1
R4(config-if)#ipv6 ospf 1 area 0
R4(config-if)#int lo0
R4(config-if)#ipv6 ospf 1 area 0
R4(config-if)#end

 

buat R5 

R5#conf t
R5(config)#ipv6 unicast-routing
R5(config)#int lo 0
R5(config-if)#ipv6 add 5::5/128
R5(config-if)#int fa0/0
R5(config-if)#ipv6 add 56::5/64
R5(config-if)#no sh
R5(config-if)#int fa0/1
R5(config-if)#ipv6 add 35::5/64
R5(config-if)#no sh
R5(config-if)#exit
R5(config)#ipv6 router ospf 1
R5(config-rtr)#router-id 5.5.5.5
R5(config-rtr)#exit
R5(config)#int fa0/0
R5(config-if)#ipv6 ospf 1 area 0
R5(config-if)#int fa 0/1
R5(config-if)#ipv6 ospf 1 area 0
R5(config-if)#int lo0
R5(config-if)#ipv6 ospf 1 area 0
R5(config-if)#end

banyak ya !!!! …  hahaha .. ayoo terus …

 

buat R6

R6#conf t
R6(config)#ipv6 unicast-routing
R6(config)#int lo0
R6(config-if)#ipv6 add 6::6/128
R6(config-if)#int fa 0/0
R6(config-if)#ipv6 add 56::6/64
R6(config-if)#no sh
R6(config-if)#int fa 0/1
R6(config-if)#ipv6 add 46::6/64
R6(config-if)#no sh
R6(config-if)#exit
R6(config)#ipv6 router ospf 1
R5(config-rtr)#router-id 5.5.5.5
R6(config-rtr)#int lo0
R6(config-if)#ipv6 ospf 1 area 0
R6(config-if)#int fa0/0
R6(config-if)#ipv6 ospf 1 area 0
R6(config-if)#int fa 0/1
R6(config-if)#ipv6 ospf 1 area 0
R6(config-if)#end

Kalau sudah semua sekarang kita coba cek routing tabel dulu sebelum melakukan distribution:

 

dari R1 dan R4 lakukan perintah #sh ipv6 route

R1#sh ipv6 route

IPv6 Routing Table - Default - 15 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
LC  1::1/128 [0/0]
     via Loopback0, receive
C   12::/64 [0/0]
     via FastEthernet0/0, directly connected
L   12::1/128 [0/0]
     via FastEthernet0/0, receive
C   13::/64 [0/0]
     via FastEthernet0/1, directly connected
L   13::1/128 [0/0]
D   2::2/128 [90/156160]
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
D   3::3/128 [90/156160]
     via FE80::C805:13FF:FEF4:8, FastEthernet0/1
D   24::/64 [90/30720]
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
D   35::/64 [90/30720]
     via FE80::C805:13FF:FEF4:8, FastEthernet0/1
L   FF00::/8 [0/0]
     via Null0, receive

 

R4#sh ipv6 route

IPv6 Routing Table - Default - 15 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D   1::1/128 [90/158720]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
D   2::2/128 [90/156160]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
D   3::3/128 [90/161280]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
LC  4::4/128 [0/0]
     via Loopback0, receive
O   5::5/128 [110/2]
     via FE80::C801:DFF:FE58:6, FastEthernet0/1
O   6::6/128 [110/1]
     via FE80::C801:DFF:FE58:6, FastEthernet0/1
D   12::/64 [90/30720]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
D   13::/64 [90/33280]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
C   24::/64 [0/0]
     via FastEthernet0/0, directly connected
L   24::4/128 [0/0]
     via FastEthernet0/0, receive
D   35::/64 [90/35840]
     via FE80::C803:12FF:FE1C:6, FastEthernet0/0
C   46::/64 [0/0]
     via FastEthernet0/1, directly connected
L   46::4/128 [0/0]
     via FastEthernet0/1, receive
O   56::/64 [110/2]
     via FE80::C801:DFF:FE58:6, FastEthernet0/1
L   FF00::/8 [0/0]
     via Null0, receive

Dapat kita lihat di atas bahwa belum ada tipe routing external yang masuk ke dalam routing tabel, Ok sekarang kita akan masukin routing table dari luar dengan cara redistribution pada kedua titik (Eigrp dan OSPF)

Pertama sekali kita harus buat route-mapnya dulu, hal ini penting agar kita dapat melakukan tagging kepada tabel yang masuk dan keluar dari tabel. Tujuan tagging disini adalah untuk melakukan tanda kepada entri tabel sehingga dapat dikenali. Jika entri sudah di tag kita dapat dengan mudah  melakukan blok kepada entri tersebut agar tidak masuk kembali ke dalam tabel routingan sehingga potensi untuk looping dapat dicegah.

 

Perintah untuk buat route map pada R3 dan R4

R3

R3(config)#route-map EIGRPtoOSPF deny 10
R3(config-route-map)#match tag 120
R3(config-route-map)#exit
R3(config)#route-map EIGRPtoOSPF permit 20
R3(config-route-map)#set tag 90
R3(config-route-map)#route-map OSPFtoEIGRP deny 10
R3(config-route-map)#match tag 90
R3(config-route-map)#route-map OSPFtoEIGRP permit 20
R3(config-route-map)#set tag 120
R3(config-route-map)#exit
R3(config-rtr)#redistribute ospf 1 metric 1 1 1 1 1 route-map 
OSPFtoEIGRP include-connected
R3(config-rtr)#redistribute eigrp 1 metric 20 route-map 
EIGRPtoOSPF include-connected

 

R4

R4(config)#route-map EIGRPtoOSPF deny 10
R4(config-route-map)#match tag 120
R4(config-route-map)#exit
R4(config)#route-map EIGRPtoOSPF permit 20
R4(config-route-map)#set tag 90
R4(config-route-map)#route-map OSPFtoEIGRP deny 10
R4(config-route-map)#match tag 90
R4(config-route-map)#route-map OSPFtoEIGRP permit 20
R4(config-route-map)#set tag 120
R4(config-route-map)#exit
R4(config-rtr)#redistribute ospf 1 metric 1 1 1 1 1 route-map 
OSPFtoEIGRP include-connected
R4(config-rtr)#redistribute eigrp 1 metric 20 route-map 
EIGRPtoOSPF include-connected

 

Kita cek sekali lagi untuk R1 apakah entrinya sudah masuk

R1#sh ipv6 route
IPv6 Routing Table - Default - 15 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
LC  1::1/128 [0/0]
     via Loopback0, receive
D   2::2/128 [90/156160]
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
D   3::3/128 [90/156160]
     via FE80::C805:13FF:FEF4:8, FastEthernet0/1
EX  4::4/128 [170/2560005376], tag 120
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
EX  5::5/128 [170/2560005376], tag 120
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
EX  6::6/128 [170/2560005376], tag 120
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
C   12::/64 [0/0]
     via FastEthernet0/0, directly connected
L   12::1/128 [0/0]
     via FastEthernet0/0, receive
C   13::/64 [0/0]
     via FastEthernet0/1, directly connected
L   13::1/128 [0/0]
     via FastEthernet0/1, receive
D   24::/64 [90/30720]
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
D   35::/64 [90/30720]
     via FE80::C805:13FF:FEF4:8, FastEthernet0/1
EX  46::/64 [170/2560005376], tag 120
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
EX  56::/64 [170/2560005376], tag 120
     via FE80::C803:12FF:FE1C:8, FastEthernet0/0
L   FF00::/8 [0/0]
     via Null0, receive

 

Terlihat bahwa entri luar sudah masuk, ditandai dengan EX (external), cek lagi untuk detail 1 routing entri dengan perintah

#sh ipv6 route 6::6/128

R1#sh ipv6 route 6::6/128
Routing entry for 6::6/128
  Known via "eigrp 1", distance 170, metric 2560005376
  Tag 120, type external
  Route count is 1/1, share count 0
  Routing paths:
    FE80::C803:12FF:FE1C:8, FastEthernet0/0
      Last updated 00:36:15 ago

Pada R6 juga kita cek,

R6#sh ipv6 route 1::1/128
Routing entry for 1::1/128
  Known via "ospf 1", distance 110, metric 20
  Tag 90, type extern 2
  Route count is 1/1, share count 0
  Routing paths:
    FE80::C804:13FF:FEF4:6, FastEthernet0/1
      Last updated 00:37:12 ago

Seperti terlihat pada kata-kata yang di bold bahwa entri yang masuk sudah ditandai dengan tag 120 dan 90. Tag 120 menandakan bahwa network tersebut berasal dari OSPF dan sudah dilakukan aturan agar network tersebut tidak masuk kembali ke dalam routing OSPF, dan hal ini juga berlaku untuk tag 90 yang berasal dari network EIGRP. Hal ini dilakukan untuk mencegah terjadinya looping.

Written by virusccie

December 8, 2011 at 8:38 pm

Posted in EIGRP, IPv6, OSPF

OSPF penuh warna

leave a comment »

OSPF termasuk ke dalam link state routing protokol, yaitu protokol yang memiliki seluruh map dari jaringan dimana dia berada, tidak seperti distance vector yang dikatakan sebagai biang gosip .. routing by rumor ..

Untuk lab OSPF aku akan pilih topologi NBMA .. silahkan dicicipin 🙂

ini topologinya: ini diambil dari lab ccie bootcamp bagian OSPF, tapi aku gabungin jadi satu aja biar ga ribet, nantinya didalam topologi ini kita akan belajar tentang OSPF NBMA, Virtual Link, Area Summarization, dan  NSSA.

Berikut konfigurasinya :

konfig R1

R1>en
R1#conf t
R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#int se 0/0
R1(config-if)#en fr
R1(config-if)#ip add 123.123.123.1 255.255.255.0
R1(config-if)#frame
R1(config-if)#frame-relay map ip 123.123.123.2 102 br
R1(config-if)#frame-relay map ip 123.123.123.3 103 br

R1(config-if)#end

R2

R2>en
R2#conf t
R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#int se 0/1
R2(config-if)#en fr
R2(config-if)#ip add 123.123.123.2 255.255.255.0
R2(config-if)#frame-relay map ip 123.123.123.1 201 br
R2(config-if)#frame-relay map ip 123.123.123.3 201
R2(config-if)#no sh
R2(config-if)#end

R3

R3#conf t
R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config-if)#int se 0/2
R3(config-if)#no sh
R3(config-if)#en fr
R3(config-if)#ip add 123.123.123.3 255.255.255.0
R3(config-if)#frame-relay map ip 123.123.123.1 301 br
R3(config-if)#frame-relay map ip 123.123.123.2 301
R3(config-if)#en

Setelah semua sudah di konfigur, lalu cek frame relay-nya .. apakah aman-aman aja atau tidak, cek dengan perintah  #show frame-relay

R1#sh frame-relay map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active

lakukan ping pong juga untuk melihat koneksinya.

R1#ping 123.123.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/67/152 ms
R1#ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/52/80 ms

ok.. frame relay tidak ada problemo .. selanjutnya kita setting untuk OSPF-nya

R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int se 0/2
R3(config-if)#ip ospf priority 0  //supaya tidak ikutan dalam pemilihan DR dan BDR//
R3(config-if)#end

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int se 0/1
R2(config-if)#ip ospf priority 0
R2(config-if)#end

R1#sh ip ospf nei

ko tidak ada neighbornya?? .. kalo gini berarti tidak akan terjadi pertemanan diantara mereka .., hmm cobba kita cek jenis apa OSPF ini ?

R1#sh ip ospf int se0/0
Serial0/0 is up, line protocol is up
  Internet Address 123.123.123.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 123.123.123.1
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:22
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

wah .,,, pantas,,  kalau tipe non broadcast ini sampai ayam tumbuh gigi juga ga bakalan muncul .. karena memang di setting ga bakalan ngirim multicast apalagi broadcast … ada 2 cara untuk mecahin masalah ini, bisa ganti tipe networknya atau tambahin statement neighbor di dalam router ospf, nah disini kan kita mau nge-lab OSPF yang NBMA jadi jangan diganti tipe networknya ntar judulnya ganti juga donk .. nah kita pakai solusi yang tambahin statement neighbor .,

perintahnya seperti berikut:

R1(config-router)#neighbor 123.123.123.2
R1(config-router)#neighbor 123.123.123.3 

R1(config-router)#end

Lalu cek kembali neighbornya …

R1#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/DROTHER    00:01:48    123.123.123.2   Serial0/0
3.3.3.3           0   FULL/DROTHER    00:01:46    123.123.123.3   Serial0/0
R2#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:01:38    123.123.123.1   Serial0/1
R3#sh ip ospf nei
Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/DR         00:01:52    123.123.123.1   Serial0/2

Lalu bagian paling mendebarkan .., cek routing tabelnya…

R1#sh ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 123.123.123.2, 00:08:06, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:08:06, Serial0/0
R2#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:08:12, Serial0/1
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:08:12, Serial0/1
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:08:32, Serial0/2
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 123.123.123.2, 00:08:32, Serial0/2

dan akhirnya  semua berjalan dengan tertib

Ok .. OSPF NMBA berhasil kita lakukan , sekarang virtual-link .. apa itu virtual link, nah logikanya gini, si OSPF kan punya area area, backbonenya ada di area , jika ada area lain yang tidak berada di dekat atau bersebelahan dengan area 0 maka dia tidak akan mendapatkan update terbaru dari router-router lainnya, artinya dia tidak ikut dalam jaringan, untuk mengatasinya kita harus mengaitkan area tersebut ke area 0 ..

tapi kan jarak router di areanya jauh dan ga kena ke arae 0, gpp kita bisa atur ..  wani piro?? 😀  ,..  ayo gimana caranya…

satu cara yang dilakukan adalah menggunakan virtual link, jadi idenya kita akan membuat link bayangan untuk menghubungkan area 0 ke area yang akan kita sambungkan tadi.

Written by virusccie

December 8, 2011 at 8:20 pm

Posted in OSPF

RIPv2 lanjut … lab redistribute EIGRP

leave a comment »

… hmm.. coba kita lihat lagi topologi di page sebelumnya ,, ada 1 router nganggur tuh .. kita apain yak .. ..

 

ok gimana kalau kita melakukan redistributed dari EIGRP ke RIP 🙂 .. sounds great tuh …

Redistributed merupakan cara yang digunakan untuk memasukkan (baca: injek) entri tabel dari satu routing protokol ke routing protokol lain atau dapat juga dipakai untuk memasukkan entri ke dalam routing tabel (contoh untuk static dan connected).

 

pada R5 kita lakukan config

R5

R5(config)#int se0/0
R5(config-if)#ip add 172.15.1.5 255.255.255.0
R5(config)#int lo0
R5(config-if)#ip add 10.0.0.1 255.255.255.0
R5(config)#int lo1
R5(config-if)#ip add 10.0.1.1 255.255.255.0
R5(config)#int lo2
R5(config-if)#ip add 10.0.2.1 255.255.255.0
R5(config)#exit
R5(config)#router eigrp 100
R5(config-router)#net 0.0.0.0
R5(config-router)#no auto

sedangkan pada R3 kita tambahin config ..

 

R3

R3(config)#int se0/1
R3(config-if)#ip add 172.15.1.3 255.255.255.0
R3(config)#router eigrp 100
R3(config-router)#net 0.0.0.0
R3(config-router)#no auto

 

Baik .., coba kita lihat routing tabelnya pada R3

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile,
B - BGP D - EIGRP, EX - EIGRP external, O - OSPF,
IA - OSPF inter area N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2 E1 - OSPF external type 1,
E2 - OSPF external type 2, i - IS-IS, su - IS-IS summary,
L1 - IS-IS level-1, L2 - IS-IS level-2 ia -IS-IS inter area,
 * - candidate default, U - per-user static route o - ODR,
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.123.1.1, 00:00:24, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 10.123.1.2, 00:00:24, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
172.15.0.0/24 is subnetted, 1 subnets
C       172.15.1.0 is directly connected, Serial0/1
10.0.0.0/24 is subnetted, 7 subnets
D       10.0.2.0 [90/2297856] via 172.15.1.5, 00:00:39, Serial0/1
D       10.0.0.0 [90/2297856] via 172.15.1.5, 00:00:40, Serial0/1
D       10.0.1.0 [90/2297856] via 172.15.1.5, 00:00:40, Serial0/1
C       10.123.1.0 is directly connected, Serial0/0

Dapat kita lihat bahwa routing dari RIP dan EIGRP kelihatan semua tapi apakah R1 bisa ngelihatnya.. kita cek:


R1#sh ip route rip

2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 10.123.1.2, 00:00:23, Serial0/0.123
3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 10.123.1.3, 00:00:21, Serial0/0.123
172.15.0.0/24 is subnetted, 1 subnets
R       172.15.1.0 [120/1] via 10.123.1.3, 00:00:21, Serial0/0.123

hmm., tidak ..

R1 masih memiliki 3 entri, ok ok kita akan nasukin tuh routing dari eigrp ke rip langsung aja tambahin perintah ini di R3

 

R3

R3#conf t
R3(config)#router rip
R3(config-router)#ver 2
R3(config-router)#redistribute eigrp 100 metric 1
R3(config-router)end

Sekarang kita lihat lagi routing tabel di R1

 

R1

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile,
B - BGP D - EIGRP, EX - EIGRP external, O - OSPF,
IA - OSPF inter area N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary,
L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area,
* - candidate default, U - per-user static route o - ODR,
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 10.123.1.2, 00:00:17, Serial0/0.123
3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 10.123.1.3, 00:00:15, Serial0/0.123
172.15.0.0/24 is subnetted, 1 subnets
R       172.15.1.0 [120/1] via 10.123.1.3, 00:00:15, Serial0/0.123
10.0.0.0/24 is subnetted, 7 subnets
R       10.0.2.0 [120/1] via 10.123.1.3, 00:00:08, Serial0/0.123
R       10.0.0.0 [120/1] via 10.123.1.3, 00:00:09, Serial0/0.123
R       10.0.1.0 [120/1] via 10.123.1.3, 00:00:09, Serial0/0.123
C       10.123.1.0 is directly connected, Serial0/0.123

 

dan .. waaallaa .. entrinya bertambah jadi banyak hasil dari EIGRP,, tapi coba kita liat R5

R5#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile,
B - BGP D - EIGRP, EX - EIGRP external, O - OSPF,
IA - OSPF inter area N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,
E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary,
L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area,
* - candidate default, U - per-user static route o - ODR,
P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2297856] via 172.15.1.1, 00:23:06, Serial0/0
172.15.0.0/24 is subnetted, 1 subnets
C       172.15.1.0 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 7 subnets
C       10.0.2.0 is directly connected, Loopback2
C       10.0.3.0 is directly connected, Loopback3
C       10.0.0.0 is directly connected, Loopback0
C       10.0.1.0 is directly connected, Loopback1
C       10.0.4.0 is directly connected, Loopback4
C       10.0.5.0 is directly connected, Loopback5
D       10.123.1.0 [90/2681856] via 172.15.1.1, 00:15:49, Serial0/0

hmm .. tidak muncul update dari rip .., ya karena kita belum redistribute si RIP ke dalam EIGRP, ntar aja ya .. kan masih belajar RIP.

sekarang kita cek ping ke R5 dari R1

 

R1

R1#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/58/84 ms

 

seep, terlihat 10.0.0.1 bisa di ping dari R1.

ok, next nih … hehe  sabar ya .. soalnya bootcampnya padat jadwalnya, jadi kadang ga sempat nulis blog .. hehe ikuti terus blog ini ..

Written by virusccie

December 5, 2011 at 3:19 pm

Posted in RIP

RIPv2 lanjut … lab authentication

leave a comment »

.. nah kira-kira bisa ga kita kasi fungsi security pada RIP, soalnya biar orang-orang yang ga berkepentingan dan sok mantab ga gampang masuk ke dalam jaringan… hmm bisa pastinya ..

dalam RIP dikenal fungsi security pada authentikasinya, artinya agar dapat dikenali dalam jarinngan kita harus punya password .. bukan quiz aja yang ada passwordnya ..

Authentication pada RIP ada 2 yaitu :

MD5 dan Clear text

 

MD5 akan melakukan encryption dengan message digest .. apa itu message digest –> nanti ya dalam page security  😀 ..,, sedangkan clear text akan mengirimkan password dalam belum clear text (kelihatan coy di jaringan)

ok kita akan mengkonfigure router- router kita tadi agar memiliki *pelindung*

 

Topologinya pake yg sama ya … dipage sebelumnya …  biar gampang ofreknya… jadi tinggal nambah-nambah config aja. ok langsung aja …

pada R1, R2 dan R3 kita tambahin config seperti di bawah ini:

 

konfig pada R1

R1(config)#key chain RIP
R1(config-keychain)#key 1
R1(config-keychain-key)#key-string CISCO
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#int se 0/0.123
R1(config-subif)#ip rip authentication mode md5
R1(config-subif)#ip rip authentication key-chain RIP

 

ini buat R2

R2(config)#key chain RIP
R2(config-keychain)#key 1
R2(config-keychain-key)#key-string CISCO
R2(config-keychain-key)#exit
R2(config-keychain)#exit
R2(config)#int se 0/0
R2(config-if)#ip rip auth
R2(config-if)#ip rip authentication mode md5
R2(config-if)#ip rip
R2(config-if)#ip rip auth
R2(config-if)#ip rip authentication key-chain RIP
R2(config-if)#end

 

untuk R3

R3(config)#key chain RIP
R3(config-keychain)#key 1
R3(config-keychain-key)#key-string CISCO
R3(config-keychain-key)#exit
R3(config-keychain)#exi
R3(config)#int se 0/0
R3(config-if)#ip rip authentication mode md5
R3(config-if)#ip rip auth
R3(config-if)#ip rip authentication key-chain RIP
R3(config-if)#end

sudah semua,,

kalau sudah kita akan cek dengan cara melakukan debug pada R1..  ayooo


R1#debug ip rip

*Mar  1 02:58:50.427: RIP: received v2 update from 10.123.1.3 on Serial0/0.123
*Mar  1 02:58:50.431:      2.2.2.2/32 via 10.123.1.2 in 3 hops
*Mar  1 02:58:50.431:      3.3.3.3/32 via 0.0.0.0 in 1 hops
*Mar  1 02:58:50.435:      10.123.1.0/24 via 0.0.0.0 in 1 hops
*Mar  1 02:58:53.699: RIP: received packet with MD5 authentication
*Mar  1 02:58:53.703: RIP: received v2 update from 10.123.1.2 on Serial0/0.123

yup .. seperti yang terlihat pada warna merah di atas ,, dari debug kelihatan paket yang terkirim menggunakan autentikasi MD5 (message digest)

Mari kita lakukan test ping sekali lagi

R1#sh ip route rip
2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 10.123.1.2, 00:00:18, Serial0/0.123
3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 10.123.1.3, 00:00:22, Serial0/0.123

 

kemudian lakukan ping ke R2 dan R3

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/39/108 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/31/56 ms

 

Yes berhasil sekarang router kita aman dan berpelindung 😀  ..  next apa nih?

Written by virusccie

December 5, 2011 at 3:18 pm

Posted in RIP

RIPv2 …

leave a comment »

Hari kedua — 4 Desember 2011 jam 09.00 WIB

Pelajaran hari ini mulai dengan membahas RIPv2 –> iya benar RIPv2 , kenapa bukan versi 1 ??

jawabannya simpel..

 

  • Pertama karena versi 1 ga keren brai… beneran 😀
  • Kedua karena versi 1 ga dimasukin di CCIE R&S blueprint, walaupun RIP itu masuk (alasannya karena versi 1 ga support classless) hari gini ga support– hahaii
  • Ketiga , karena versi 3 belum ada 😛 😛 (ada juga RIPng, itupun buat IPv6, ntar deh tunggu aku launching yang versi 3-nya)

 

Ok kita mulai langsung ke RIPv2 yah.

RIP menggunakan port UDP 520 untuk berkomunikasi antara pengirim dan penerima message dalamn network.

Ada 2 jenis message yang dikenal pada RIP yaitu :

Request Message adalah message yang digunakan untuk meminta update dari neighbor.

Response Message adalah pesan yang membawa update ke neighbor.

Metric yang digunakan adalah hop count dengan jumlah maksimal 15, dan akan menjadi unreachable jika melebihinya

(16 tidak akan dapat dijangkau)

 

4 timer yang digunakan adalah

Update — 30 detik

merupakan update yang membawa seluruh isi tabel dengan periode 30 detik sekali dan dikirim melalui multicast ke alamat 224.0.0.9

Holddown – 180 detik

merupakan nilai yang digunakan jika metrik pada router berubah dan akan menunggu sampai waktu holddown habis baru dapat menerima update dari router lain, nilai in hanya ada di Cisco.

Invalid – 180 detik

jika dalam waktu 180 detik router tidak memberikan updatenya maka router tersebut akan dinyatakan dengan invalid, dengan routenya ditandain dengan “inaccessibel.

Flush – 240 detik

nilai yang diberikan kepada router untuk mengupdate informasinya, jika waktu ini habis maka informasi tentang router tersebut akan dihapus.

Ketika RIP pertama sekali di nyalakan maka router akan mengirimkan request message ke semua interface RIP yang aktif, atau melewati network interface yang telah didaftarkan dalam network.

 

contoh

R1#(config-router)net 0.0.0.0

pada konfigurasi tersebut RIP akan melewati semua network interface yang ada.

 

langsung ya….  ini lab yang akan kita ofrek ..  ini pake GNS3 .. dalam topology ini aku akan bahas beberapa lab jadi topologynya ga usah diganti-ganti cukup pakai ini ya…   nah untuk lab pertama kita akan membahas mengenai RIP Split Horizon ..

selamat menikmati ….

 

 

Konfigurasinya :

Ketik konfig ini di R1

R1#conf t
R1(config)#int se 0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#int se 0/0.123 multipoint
R1(config-subif)# ip address 10.123.1.1 255.255.255.0
R1(config-subif)# frame-relay map ip 10.123.1.2 102 broadcast
R1(config-subif)# frame-relay map ip 10.123.1.3 103 broadcast

/* melakukan static mapping ke 2 tujuan ip spoke R2 dan R3*/

R1(config-subif)#exit
R1(config-if)#exit
R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#ver 2

/*untuk menentukan versi dari RIP, versi  1 merupakan default */

R1(config-router)#net 0.0.0.0

/* mendaftarkan semua network pada RIP

R1(config-router)#no auto

 

yang ini di R2

R2#conf t
R2(config)#int se 0/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#ip add 10.123.1.2 255.255.255.0
R2(config-if)# frame -relay map ip 10.123.1.1 201 broadcast
R2(config-if)# frame -relay map ip 10.123.1.3 201

/* melakukan static mapping ke R1 dan R3*/

R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#ver 2
R2(config-router)#net 0.0.0.0
R2(config-router)#no auto

 

buat R3

R3#conf t
R3(config)#int se 0/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#ip add 10.123.1.3 255.255.255.0
R2(config-if)# frame -relay map ip 10.123.1.1 301 broadcast
R3(config-if)# frame -relay map ip 10.123.1.2 301

/* melakukan static mapping keR1 dan R2 */

R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config-if)#exit
R3(config)#router rip
R3(config-router)#ver 2
R3(config-router)#net 0.0.0.0
R3(config-router)#no auto

 

dan buat FRSW

FRSW#conf t
FRSW(config)# frame-relay switching

/*untuk mengaktifkan switching frame relay*/

FRSW (config)#int se 0/0
FRSW (config-if)#  encapsulation frame-relay
FRSW (config-if)# frame-relay lmi-type cisco
FRSW (config-if)#  frame-relay intf-type dce
FRSW (config-if)#  frame-relay route 102 interface Serial0/1 201

/*untuk me-route R1 ke R2*/

FRSW (config-if)#  frame-relay route 103 interface Serial0/2 301

/*untuk me-route R1 ke R3*/

FRSW (config)#int se 0/1
FRSW (config-if)# encapsulation frame-relay
FRSW (config-if)# frame-relay lmi-type cisco
FRSW (config-if)#  frame-relay intf-type dce
FRSW (config-if)#  frame-relay route 201 interface Serial0/0 102 
/*untuk me-route R2 ke R1*/
FRSW (config)#int se 0/2
FRSW (config)#encapsulation frame-relay
FRSW (config)#frame-relay lmi-type cisco
FRSW (config)# frame-relay intf-type dce
FRSW (config)# frame-relay route 301 interface Serial0/0 103 
/*untuk me-route R3 ke R1*/

 

Kalau semua sudah diconfig semua, sekarang kita cek satu persatu ya !!..

Periksa frame relay map dulu

dari R1 lakukan cek dengan perintah *sh frame-relay map*

R1#sh frame-relay map
Serial0/0.123 (up): ip 10.123.1.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial0/0.123 (up): ip 10.123.1.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active

yup seperti terlihat status active.

lakukan juga untuk R2 dan R3 dengan perintah yang sama.

 

cek R2

R2#sh frame-relay map
Serial0/0 (up): ip 10.123.1.1 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 10.123.1.3 dlci 201(0xC9,0x3090), static,
CISCO, status defined, active

 

cek R3

R3#sh frame-relay map
Serial0/0 (up): ip 10.123.1.1 dlci 301(0x12D,0x48D0), static,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 10.123.1.2 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active

Periksa juga routing table dan lakukan test ping

 

R1

R1#sh ip route rip
2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 10.123.1.2, 00:00:01, Serial0/0.123
3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/1] via 10.123.1.3, 00:00:21, Serial0/0.123
R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/23/40 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/36/104 ms

 

R2

R2#sh ip route rip
1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.123.1.1, 00:00:01, Serial0/0

*/ eittss   perhatikan 3.3.3.3 hilang dari routing table .. tanya kenapa???*/

R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/56 ms

coba ping dulu kali aja bisa …   ok ok

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Seperti yang terlihat bahwa 3.3.3.3 tidak dapat dijangkau..  ya kan ga muncul di routing table.

 

R3

R3#sh ip route rip
1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.123.1.1, 00:00:22, Serial0/0

*/  perhatikan juga 2.2.2.2 hilang dari routing table .. tanya juga  kenapa???*/

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/30/52 ms

Alasannya kenapa ya???

– Pertama sekali coba kita lihat kembali topologinya … yup benar hup and spoke dengan frame relay di tengahnya, so ..

lalu perhatikan interface s0/0 pada R1..

hmm,  ada sub interface multipoint, lalu kenapa??

artinya main interfacenya pasti akan memberlakukan split horizon…  jika interface s0/0 menerima packet ke dalam dirinya , interface tersebut tidak akan memberitahu informasinya balik ke si pemberi, artinya main interface menganggap si pemberi dan penerima packet adalah interface yang sama, maka split horizonnya pun enabled.

Untuk mengatasi ini kita harus men-nonaktifkan fungsi split horizonnya.

ayo kita cek dulu di se0/0.123

R1#sh ip int se0/0.123 | inc Split

Split horizon is enabled  –> ini biang keroknya (ingat split horizon berguna untuk yang tipe network full mesh tapi buruk buat yang tipe point-to-multipoint)

kita harus men-nonaktifkan split horizon pada sub interface itu agar R2 mengenali routing dari R3 dan sebaliknya.

R1(config)#int se 0/0.123
R1(config-subif)#no spl
R1(config-subif)#no ip spl
R1(config-subif)#no ip split-horizon

Ok kita cek lagi routing table pada R2 dan R3

 

R2

R2#sh ip route rip
1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.123.1.1, 00:00:10, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/2] via 10.123.1.3, 00:00:10, Serial0/0
R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/70/148 ms

 

R3

R3#sh ip route rip
1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 10.123.1.1, 00:00:03, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 10.123.1.2, 00:00:03, Serial0/0
R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/60/104 ms

 

Yes, seperti terlihat bahwa routing table pada R2 dan R3 sudah di update.

R2 dapat melakukan ping ke 3.3.3.3 dan R3 dapat melakukan ping ke 2.2.2.2

Ok .. lanjut ke permainan selanjutnya…

Written by virusccie

December 5, 2011 at 2:58 pm

Posted in RIP

Siapakah frame relay ??

leave a comment »

FrameRelay merupakan teknologi packet-switching, packet switching disini berarti tiap “end station” dapat berbagi bandwidth dalam satu medium yang sama (menggunakan media rame-rame gak kayak telepon yang pake kabel sendirian 64 kbps).

Alat yang digunakan jika kita akan menerapkan teknologi frame relay adalah:

Data terminal equipment (DTE)   ,pada lab inikenal sebagai router

Data circuit-terminating euipment (DCE),  di blog akan dikenal sebagai FRSW (Frame Relay Switch)

 

Frame Relay sebenarnya sudah tidak banyak digunakan dalam network jaringan, tapi bahan ini tetap dimasukkan ke dalam blue print CCIE R&S, jadi buat kit yang ingin ujian Lab, materi ini harus harus dipelajari benar karena frame relay pasti akan muncul di sesi troubleshoot dan lab configuration. Materi frame relay yang akan ditemui dalam sesi troubleshoot akan lebih sulit dan kompleks so rajin berlatih ya ….

 

Ada beberapa tipe yang harus benar-benar diketahui pada frame relay:

  • Point to point

Tidak membutuhkan mapping L2 ke L3, karena hanya terdapat 1 DLCI saja, contoh perintah untuk membuat interface point-to-point –> interface se 0/0.1 point-to-point.

  • Point-to-multipoint

Membutuhkan L2 ke L3 mapping, dapat dilakukan secara dynamic menggunakan inverse-arp yaitu frame-relay interface dlci atau dapat menggunakan static mapping dengan perintah frame-relay map.

  • Hub and spoke

Hub merupakan penghubung antara spoke, sehingga spoke membutuhkan hub agar dapat berkomunikasi.

Pada tipe ini kita dapat menggunakan inverse-arp (dynamic mapping) tapi hanya berlaku untuk hubungan hup dan spoke, dan antar spoke tetap tidak bisa berkomunikasi. Keadaan ini dapat diatasi dengan menggunakan static mapping (Frame-relay map).

Penggunaan broadcast keyword cukup yang menuju ke hub saja.

 

Berikut contoh sederhana frame relay diambil dari lab 1 CCIE bootcamp IDN:

 

Frame Rekay Inverse-ARP

                             

ada tiga router R1, R2 dan FRSW
Konfigurasi untuk R1

R1(config)#int se 0/0
R1(config-if)ip add 10.12.1.1 255.255.255.0
R1(config-if)encapsulation frame-relay
R1(config-if)no shutdown

 

Konfigurasi untuk R2

R2(config)#int se 0/1
R2(config-if)ip add 10.12.1.2 255.255.255.0
R2(config-if)encapsulation frame-relay
R2(config-if)no shutdown

 

Konfigurasi untuk FRSW (frame Relay Switch)

FRSW(config)#frame-relay switching
FRSW(config)int se 0/0
FRSW(config-if)encapsulation frame-relay
FRSW(config-if)frame-relay intf-type dce
FRSW(config-if)frame-relay lmi-type cisco
FRSW(config-if)frame-relay route 102 interface s0/1 201
FRSW(config-if)no shutdown
FRSW(config)int se 0/1
FRSW(config-if)encapsulation frame-relay
FRSW(config-if)frame-relay intf-type dce
FRSW(config-if)frame-relay lmi-type cisco
FRSW(config-if)frame-relay route 201 interface s0/1 102
FRSW(config-if)no shutdown

 

Setelah dikonfig semua lalu lakukan test ping dari R1 ke R2

R1#ping 10.12.1.2
Type escape sequence to abort.
 Sending 5, 100-byte ICMP Echos to 10.12.1.2, timeout is 2 seconds:
 !!!!!
 Success rate is 100 percent (5/5), round-trip min/avg/max = 8/38/56 ms

 

Lakukan sh frame-relay map untuk melihatmapping frame relay ..

R1#sh frame-relay map
 Serial0/0 (up): ip 10.12.1.2 dlci 102(0x66,0x1860), dynamic,
 broadcast,, status defined, active

 

Semua aktif berarti frame relay telah terkoneksi satu dengan lainnya, dan kita sukses hehe

ok untuk lab-lab lainnya menyusul di page berikut ya , so sabaaaar..  🙂

Written by virusccie

December 4, 2011 at 7:44 am

Posted in Frame Relay

CCIE BootCamp Indonesia 2011

leave a comment »

Berawal dari searching di google mengenai bahan-bahan ccie sampai ke tutorialnya, maka mendaratnya mouse  ke satu link mengenai CCIE bootcamp.

“Mahhaaaaalll”  ..  cuma itu yang ada dipikiran ketika mendengar kata-kata bootcamp, tapi ternyata setelah ke tkp (IDN) pikiran langsung menuju satu kesimpulan .. “Ikuuuuttt”  :D.

Kapan lagi ada bootcamp yang secara hitung-hitungan sebenarnya tidak berbayar alias “Pake aja” …

3 Desember adalah hari mulai bootcamp di Cisarua dan akan diadakan selama 9 hari sampai tanggal 11 Desember nanti, dan mulailah perjalanan kita untuk mencari nomer mahal dari Cisco.

CCIE bootcamp Indonesia…,  kedengarannya baru memang dan benar,  inilah bootcamp pertama CCIE yang dilakukan di Indonesia, terlepas dari official atau nonofficial.

Mengambil tempat di Cisarua karena tempatnya yang ga cukup di mabes IDN ..    dengan jumlah peserta yang berhasil di nego sebanyak 50 orang ..  (kayak arisan…)

Acara ini dilakukan oleh IDN dan dibawakan oleh mas Dedi Gunawan aka proctor lab, dimulai dari jam 9 pagi samapai 11.30 malam.. brrr!!

Pertama yang kita lakukan adalah meet and great … kenalan dulu donk .. lalu membicarakan mengenai lab, dimana lab akan diadakan , biaya, akomodasi dan cara pendaftaran. Dan untuk update terbaru CCIE lab harganya sudah naik  jadi $1500 untuk lab dan $1750 untuk mobile lab.

Setelah penjelasan awal, lalu kelas break untuk makan siang dan memang perut sudah laper .. hehe

Makan selesai dan kita kembali ke kelas, menu pertama ada frame relay, frame relay yang ada di bootcamp ini adalah untuk ccie fundamental, artinya kita diwajibkan mengerti benar fundamentalnya, dan ini berlaku untuk semua bagian. Ada 12 lab frame-relay yang harus dikerjakan sampai jam 9 malam .. fiuuhhh  .. mantab ..   mancing m***a ..   ..

Jam 9 sampai 11.30 malam adalah waktunya sesi troubleshoot.. dan begitu berulang sampai 8 hari ke depan.

saksikan penampilan frame relay di page berikutnya 🙂 …

Written by virusccie

December 4, 2011 at 7:24 am

Posted in Umum